[Uganda] Service Alert: MTN Service Disruption

Incident Report for Flutterwave

Resolved

We are pleased to inform you that that issue affecting MTN Uganda has been successfully resolved.

Thank you for your patience and understanding.
Posted Aug 07, 2026 - 13:07 UTC

Investigating

Dear Valued Merchant,

Due to an issue affecting MTN Uganda, some merchants may experience difficulties processing customer payments, while transfers to customers may take longer than usual to be completed.

Our team is working closely with the service provider to resolve the issue and restore normal service. We will continue to keep you informed of any significant updates.

We're sorry for the inconvenience and thank you for your continued understanding.
Posted Aug 07, 2026 - 11:23 UTC