[Nigeria] Service Restored: Intermittent issues with recipient name verification

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the issue with name verification has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Jun 30, 2026 - 07:04 UTC

Identified

Dear Valued Customer,

An external banking partners is currently experiencing a technical issue. As a result, some customers may find that recipient names are not loading when trying to make transfers. Our team is actively working with the provider to get this resolved quickly. We apologize for the disruption and appreciate your understanding.

Affected Services:
Affected Markets: Nigeria
Posted Jun 29, 2026 - 18:10 UTC
This incident affected: Flutterwave Collections (Collections APIs).