[Nigeria] Service Restored: Intermittent Name Enquiry Errors

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the issue with name verification due to a technical issue with an external provider has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted May 09, 2026 - 16:53 UTC

Identified

Dear Valued Customer,

Some users may find that name verification is currently slow or failing. This is due to a technical issue with an external provider. We are working with our partner to get things back to normal. We apologize for any inconvenience.

Affected Services:
Affected Markets: Nigeria
Posted May 09, 2026 - 12:13 UTC
This incident affected: Flutterwave Collections (Collections APIs).