[3rd Party Downtime] - Pay with Paypal
Incident Report for Flutterwave
Resolved
This incident has been resolved.
Posted Apr 03, 2021 - 05:32 UTC
Investigating
Payment attempts via Paypal are currently returning response: Payment Failed. Try again with PayPal.

We do not have an estimated time to resolve.

We are investigating and will give feedback as soon as we learn more.

We apologise for any inconvenience.
Posted Apr 02, 2021 - 16:11 UTC
This incident affected: Collections.