Service glitch with Collections on SendApp, Mar 18 2026

Incident Report for Flutterwave

Resolved

Dear Valued Customer,
The service disruption impacting collections on SendApp, have been resolved, and normal operations have been restored.
Thank you for your patience and understanding.
Posted Mar 19, 2026 - 11:30 UTC

Investigating

Dear Valued Customer,

We are currently experiencing a service disruption affecting collections on SendApp.

The issue is under investigation and resolution is in progress. Updates will be provided as more information becomes available.
We apologize for the inconvenience and appreciate your understanding.
Posted Mar 19, 2026 - 09:41 UTC
This incident affected: Remittance Products (SendApp).