We are pleased to inform you that the issue with NGN pay with bank transfer has been resolved. You can now make payments without any disruption.
Thank you for your patience and understanding while we worked to fix this. We apologize for any inconvenience this may have caused.
Affected Services: Affected Markets: Nigeria
Posted Oct 18, 2025 - 05:09 UTC
Identified
Dear Valued Customer,
We are currently experiencing a service disruption on one of our NGN Pay with Bank Transfer (PWBT) rail, which impacts collection transaction processing.
Our technical team is actively working with the partner to restore full service as quickly as possible.
Further updates will be provided as soon as possible.
We sincerely apologize for any inconvenience this may cause and appreciate your patience and understanding.
Affected Services: Affected Markets: Nigeria
Posted Oct 17, 2025 - 14:13 UTC
This incident affected: Flutterwave Collections (Collections APIs).