Service Restored: Intermittent Issues with Mobile Money Debits (Ghana)

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the intermittent issue with debit transactions as a result of some technical difficulties with one of our service providers in Ghana has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Ghana
Posted Mar 06, 2026 - 07:33 UTC

Identified

Dear Valued Customer,

We are currently experiencing technical difficulties with one of our service providers. As a result, some users may find that debit transactions are failing or intermittent.

Our partner is working to fix this quickly. We will post an update as soon as the service is back to normal. We apologize for the trouble.

Affected Services:
Affected Markets: Ghana
Posted Mar 05, 2026 - 21:39 UTC
This incident affected: Flutterwave Collections (Checkout JS).