[Egypt] Service Restored: Payment Collection Disruption

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the issue with payment collections due to a service disruption with our external vendor has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets:
Posted Jun 11, 2026 - 13:50 UTC

Identified

Dear Valued Customer,

Some users may experience trouble with payment collections due to a service disruption with our external vendor. Our team is already looking into it and working on a resolution. We apologize for the inconvenience and thank you for your patience.

Affected Services:
Affected Markets:
Posted Jun 11, 2026 - 09:14 UTC
This incident affected: Flutterwave Collections (Checkout JS).