The issue affecting Payment Link processing has been resolved. Merchants can now complete payments through Payment Links as expected.
We apologize for the disruption and appreciate your patience.
Posted Aug 20, 2026 - 10:50 UTC
Update
Payment Links remain available for creation through the dashboard. However, you may experience difficulties when attempting to complete transactions through these links.
Posted Aug 20, 2026 - 10:05 UTC
Investigating
Dear Valued Merchant,
We are currently experiencing a technical issue affecting the creation and processing of Payment Links through the Flutterwave for Business (F4B) dashboard. As a result, you may be unable to create or process Payment Link transactions as expected.
Our team is actively working to restore normal service and resolve the disruption as quickly as possible.
We apologize for the inconvenience and appreciate your patience and understanding.
Posted Aug 20, 2026 - 09:54 UTC
This incident affected: Flutterwave Collections (Collections APIs) and Flutterwave for Business (Dashboard).