Service Restored: Mobile Money Collections (Uganda)

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the service disruption affecting Mobile Money collections in Uganda has been successfully resolved. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Uganda
Posted Nov 07, 2025 - 06:25 UTC

Identified

Dear Valued Customer,

We are currently experiencing a service disruption affecting Mobile Money collections in Uganda. This issue is external, originating with one of our service providers.

We have identified the issue and our technical team is actively working with the provider to resolve it.

We will share an update as soon as we have more information. We apologize for the inconvenience this is causing.

Affected Services:
Affected Markets: Uganda
Posted Nov 06, 2025 - 22:54 UTC
This incident affected: Flutterwave Collections (Collections APIs).