Service Restored: Intermittent Card Transaction Issues (Nigeria)

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the issue with card transactions due to a service disruption from our payment provider has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Apr 01, 2026 - 12:53 UTC

Identified

Dear Valued Customer,

We are currently experiencing issues with card transactions due to a service disruption from our payment provider. They are working on a fix right now.

We will let you know as soon as everything is back to normal. Thank you for bearing with us.

Affected Services:
Affected Markets: Nigeria
Posted Apr 01, 2026 - 11:15 UTC
This incident affected: Flutterwave Collections (Collections APIs).