Earlier , some users experienced delays while logging into the F4B platform. The issue has now been resolved, and login functionality is fully restored.
We sincerely apologize for the inconvenience and appreciate your patience.
Our team is monitoring the platform closely to ensure continued stability.
Thank you for choosing Flutterwave.
Best regards, The Flutterwave Team
Affected Services: F4B API Service Affected Markets: Global
Posted May 14, 2025 - 08:52 UTC
Investigating
Dear Valued Customer, We are currently investigating an intermittent issue that may cause timeouts during login on the F4B platform. Our team is actively working to resolve this and restore full functionality as quickly as possible. We sincerely apologize for any inconvenience this may cause and appreciate your patience and understanding. We will provide an update once the issue has been fully resolved. Thank you for choosing Flutterwave. Warm regards, The Flutterwave Team
Affected Services: F4B API Service Affected Markets: Global
Posted May 13, 2025 - 18:09 UTC
This incident affected: Flutterwave for Business (Flutterwave API).