Service Restored: Payment Collections (MoMo Rwanda)

Incident Report for Flutterwave

Resolved

Dear esteemed customers/merchants,

We are pleased to inform you that the technical issue affecting payment collections in Rwanda has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Rwanda
Posted Jan 08, 2026 - 11:04 UTC

Identified

Dear Valued Customer,

We are currently experiencing a technical issue affecting payment collections. Our team is working closely with our service provider to resolve this as quickly as possible.

We apologize for the inconvenience and will provide updates as soon as more information is available.

Affected Services:
Affected Markets: Rwanda
Posted Jan 08, 2026 - 09:27 UTC
This incident affected: Flutterwave Collections (Collections APIs).