[Rwanda] Service Restored: Issues with mobile money collections

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the delay with some mobile money payments in Rwanda due to a third-party service issue has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Rwanda
Posted May 03, 2026 - 14:19 UTC

Identified

Dear Valued Customer,

We are seeing a delay with some mobile money payments in Rwanda due to a third-party service issue. Our team is investigating and working on a fix. We apologize for the trouble.

Affected Services:
Affected Markets: Rwanda
Posted May 02, 2026 - 15:10 UTC
This incident affected: Flutterwave Collections (Collections APIs).