Inability to respond to Chargebacks via Flutterwave dashboard
Incident Report for Flutterwave
Resolved
This incident has been resolved
Posted Aug 26, 2020 - 13:48 UTC
Identified
We are aware of an issue preventing merchants from responding to chargebacks logged against them via Flutterwave dashboard.

We are currently working to restore normal service.

While we resolve this, merchants should forward evidence of disputed claims to disputes@flutterwavego.com so they don’t miss the deadline for chargeback claims.
Posted Aug 26, 2020 - 12:32 UTC
This incident affected: Flutterwave for Business (Dashboard).