[3rd Party Downtime] - Kenya Bank Payouts — KENYA
Incident Report for Flutterwave
Resolved
This incident has been resolved.
Posted May 28, 2021 - 08:52 UTC
Investigating
We are currently experiencing an issue with KES bank payouts, this has been escalated to our partners.

They have informed us that they currently working on this and they will keep us updated as the situation progresses.

Impact: Failure of Kenya bank payouts
Posted May 28, 2021 - 08:38 UTC
This incident affected: Payouts.