[3rd Party Downtime: Investigating] - Service Interruption Notification - M-Pesa - Collection - KENYA
Incident Report for Flutterwave
Resolved
This incident has been resolved.
Posted Mar 17, 2021 - 07:52 UTC
Investigating
We are aware that some users may be experiencing difficulties completing M-Pesa payments due to potential service interruption on Safaricom. Resolution is underway by the service provider.

We apologise for any inconvenience and will provide another update in 4 hours.

Transactions via Airtel Kenya are processing successfully.
Posted Mar 04, 2021 - 11:53 UTC
This incident affected: Flutterwave Collections (Collections APIs).