M-Pesa Collection - KENYA
Incident Report for Flutterwave
Resolved
This incident has been resolved.
Posted Jun 01, 2021 - 09:50 UTC
Investigating
We’re currently investigating a potential service interruption on M-Pesa (Kenya) causing transaction attempts to fail with the response: "Bad request-invalid amount."

We have escalated to the partner and will post another update as soon as we learn.
Posted Jun 01, 2021 - 08:38 UTC
This incident affected: Collections.