NGN Payouts
Incident Report for Flutterwave
Resolved
This incident has been resolved.
Posted Aug 01, 2021 - 09:47 UTC
Investigating
We're currently experiencing a downtime on NGN payouts, hence causing NGN payouts fail intermittently.

We regret the inconvenience this is causing you and will post an update as soon as we learn.

ETR: 3 hrs
Posted Jul 31, 2021 - 20:15 UTC
This incident affected: Payouts.