Late response to transfer requests - [Fidelity Bank] Nigeria
Incident Report for Flutterwave
Resolved
This incident has been resolved.
Posted Feb 19, 2021 - 10:42 UTC
Identified
No response to funds transfers requests. NIP transactions to Fidelity Bank are failing.

Fidelity Bank's technical team is currently working to resolve the challenge.

We shall provide an update as soon as this has been resolved.
Posted Feb 18, 2021 - 22:33 UTC
This incident affected: Payouts.